/contrib/famzah

Enthusiasm never stops

Review of the Super Micro BMC IPMI card for the X8DTL motherboards

14 Comments

This review applies for the BMC IPMI card which is installed on the following Super Micro X8DTL Xeon motherboards:

A colleague and I tested this on a X8DTL-iF motherboard using the latest IPMI firmware for “IPMI_8DTL”, revision 1.29.

My overall opinion about this IPMI software is that it doesn’t cover the stability and functional expectations for a mission-critial management interface. The previous AOC-SIM1U(+) IPMI cards for the Super Micro X7DVL-E motherboard were much, much better and usable.

So here a list with the issues, and possible workarounds for them:

  • The “Launch Console” button of the “Console Redirection” feature does nothing under Java 1.6.20 on Windows.
    Resolution: Review the other article about Super Micro IPMI Console + Java.
  • They do not use compression for the video traffic, or it’s very weak!!! For the Debian install menu @4 FPS you need about 13 MBit/s bandwidth for a single KVM console. If you are not on a LAN with the IPMI device, prepare for noticeable lag. If you are administering the IPMI device overseas, you are in trouble… Tested on Linux, Windows and Mac.
    Partial resolution: In the remote console Java applet, navigate to Options -> Preferences -> Display, and then select “Low Color (Lighter Traffic)”. This makes the traffic noticeably less. This was reported by zImage.
  • The CTRL and/or ALT keys sometimes remain pressed down, even if you haven’t used them. If you are in a Debian installer menu, this will get you quite a lot of trouble. If you are on the LILO console, you may think that the keyboard doesn’t work at all.
    Resolution: Press CTRL and then ALT shortly on your keyboard.
  • We managed to break the VNC port of the KVM console just by trying to connect to it with a VNC client on port 5900. Beware if you are exposing your IPMI device on a public IP address.
    Resolution: Re-power the whole server to fix the IPMI device. Set up ACLs for the network access to your IPMI devices. Update: As Simon commented below, you can reset the IPMI device via the web interface: Maintenance -> Unit Reset. This won’t reboot your server.
  • If you leave the network KVM console opened idle on Windows, it suddenly disconnects.
  • Changing the zoom options for the KVM console renders the screen unusable.
  • Some keys repeat even if you are on a LAN. This happens not very often though.
  • There is a slight lag for the keyboard response, even on a LAN.
  • The web interface is full of AJAX scripts. This makes it unusable on Safari. They are trying to impress System Administrators with AJAX on the mission-critical management interfaces?? Furthermore, the AJAX error-handling is terrible – if there is a connection problem and you initiated some action, the AJAX happily returns “Configuration saved”, and actually nothing gets done… Nevertheless, the web interface works in general.
  • Too much JavaScript – you cannot submit forms by hitting Enter.
    Resolution: You need to click on the “Submit” button or navigate to it via TAB and then press Enter.
  • The firmware update from 1.02 to 1.29 erased the previous IPMI config. The firmware flashing process was done via the web interface of the IPMI card.
    Resolution: First upgrade firmware, then configure the IPMI IP and other settings.
  • While configuring the IPMI via BIOS with a locally attached keyboard and monitor, there is a noticeable lag while you type.

It’s worth mentioning that the ideas they tried to implement are good – they have screen capturing feature and all the other IPMI features we had in the previous releases. Only the implementation is weak.

The OS’es we tested with are:

  • Kubuntu Karmic 32bit, Java 6.
  • Mac OS X Leopard 10.5, Java 5.
  • Windows Vista Home Premium SP1 32bit, Java 6.

So in general, this new IPMI software is a big disappointment and makes me very insecure if I can depend on this management device in a critical moment. It does work somehow, but this is not what I expect from a production-ready product.


Mar/14: I contacted Super Micro Support at their official email address (support@Supermicro.com) but got no reply. The reason I wrote them was to attract their attention to the reported bugs, and asked them if they want me to not disclose them for a while.
Mar/15: I contacted their European Support Team (support@supermicro.nl), as my colleagues advised because they are more responsible. Here is what they replied: “I have forwarded your mail to our software engineer and PM to check it. We will get back to you later“.
Later in March: They didn’t write me back any more but have released several new firmwares since then – v1.31 03/09 and v1.34 04/07. Here are the changelogs (you have to click “show source” to see them), I haven’t tried the newest firmware yet:

ATEN Firmware v1.34 04/07:
1. Fix "can't read power from ME" (ipmitool xxx raw 0x30 0xe2 00 00)
2. Fix X8SIT HDD Smart Error string spacing: Disk0 Smart failure (issue# 22816). X8SIU: Set NMI output to low when power fail.
2. H8DGU: Set GPIO34 output to low when firmware initializes (for APML, requested by hardware)
3. H8SGL, H8DGG & H8DGT: Set GPIO34 output to high when firmware initializes (for APML, requested by hardware)
4. X8DTN+(boardID 0x060f), X8DTU-LN4F+(boardID 0x060c), X8DTU-6TF(boardID 0x060d): Modify CPU temperature to display as low/medium/high (issue #22721); Modify DDR TM2 and upper threshold to 65 degrees. (issue #22795)
1. X7SPA: Add sensor +3.3VSB and VBAT to sync with BIOS sensor items (issue# 20992)
2. X7SPA, X8DTN+, H8SGL, H8DGU, H8DGG, H8DGT: Add deassertion event for chassis intrusion (issue# 22250)
3. Modify power supply status to use GPIO for X8DTN+ (issue# 22490)

ATEN Firmware v1.31 03/15:
1. Add X8DTU-6TF sensor reading (new board)
2. H8DGU & H8SGL: Fix CPU temperature does not change (issue# 20868 & 22477)
3. Fix the issue iKVM record video and screen capture does not work under MAC OS.
4. Fix the issue preferences cannot be saved in full screen mode under MAC OS.
5. Fix the issue Japanese web is no longer working.

ATEN Firmware v1.31 03/09:
1. H8DGU & H8SGL: Fix CPU temperature does not change (issue# 20868 & 22477)
2. Fix the issue iKVM record video and screen capture does not work under MAC OS.
3. Fix the issue preferences cannot be saved in full screen mode under MAC OS.
4. Fix the issue Japanese web is no longer working.

ATEN Firmware v1.30 02/26:
1. X8SIT: Add NMI out when power fail
2. H8DGT: Add hardware monitor
3. H8DGG: Add fan control according to GPU1 and GPU2 temperature

ATEN Firmware v1.30 02/17:
1. H8DGG-QF: Add GPU temp reading and maximum fan control
2. X8DTL: Modify DIMM temp upper threshold to 85,90,95

ATEN Firmware v1.30 02/12:
1. Fix 'not able to login after flashing firmware until clear cache and reopen browser'
2. Modify IPMB to fix BMC fails during AC on/off stress test
3. Fix H8DGG sensors and H8SGL chassis intrusion
4. Fix SSL certificate issue (for X8SIL customer)

ATEN Firmware v1.29 02/05:
1. Modify H8SGL and H8DGU sensor threshold: +1.1V, CPU DIMM, and Chassis Intrusion (IssueID=21765). Please reset IPMI to 'Factory Default' on Maintenance webpage after flashing firmware.
2. Fix system shows 'BMC fails' on X8DTL (IssueID=21861)

ATEN Firmware v1.29 02/02:
1. Java KVM supports MAC OS (require java 1.6 update14+ plugin) (Please clear the cache and reopen your browser if you're not able to login after flashing firmware)
2. Support recording video as a standard video format
Advertisements

Author: Ivan Zahariev

An experienced Linux & IT enthusiast, Engineer by heart, Systems architect & developer.

14 thoughts on “Review of the Super Micro BMC IPMI card for the X8DTL motherboards

  1. I have an x8dtu, and tried various versions of the ipmi module, they all have irritating web javascript, the remote console viewer / serial viewer just doesnt seem to work at all for me. Sigh.

  2. I just recently purchased a X8DTL-iF (IPMI ver. 1.30) that had these same issues. Idid notice from reading the documentation at http://www.supermicro.com/products/nfo/IPMI.cfm that the embedded Matrox chip would do 1600×1200 but only NON-KVM. After I set resolution in xorg.conf (Debian Lenny automagically sets resolution to what the connected monitor will support) to 1280×1024 or lower that the KVM now works, albeit slowly.
    I agree that the SM IPMI java solution is woefully slow (hard to get to BIOS) and the SOL is still not working even with documented menu.lst entries for grub.
    Now I have KVM it’s time to track down why I get kernel oops with VMware vmnet and e1000e.
    I did find that latest firmware for this board is 1.31, but have not yet applied it as I don’t want the static IP entries for it wiped out when it updates.

  3. Pingback: The Super Micro IPMI Console + Java are killing me « /contrib/famzah

  4. It does not work with all Linux versions (mine may be too old)

    When I try to open the IPMI web-interface, I get the following error from Java Web Start:

    java.io.FileNotFoundException: https://10.47.123.27/iKVM.jar?version-id=1.57.1.0×0

    I am using a X8DTN+-F, BIOS version 080016, IPMI version 1.30
    The machine I am using to access it is a RHEL5 server with:
    Linux bhr-001 2.6.18-128.1.6.el5PAE #1 SMP Tue Mar 24 12:39:24 EDT 2009 i686 i686 i386 GNU/Linux
    firefox-3.0.7-1.el5.i386.rpm
    java-1.6.0-sun-1.6.0.5-1jpp.2.el5_1.i586.rpm
    java-1.6.0-sun-plugin-1.6.0.5-1jpp.2.el5_1.i586.rpm

    Firefox downloads the jnlp file and when I doubleclick it to open it, I get a screen asking me if I want to install the ATEN java iKVM viewer.
    After clicking OK, I get the following error:
    java.io.FileNotFoundException: https://10.47.123.27/iKVM.jar?version-id=1.57.1.0×0

    Any ideas?

    • Unfortunately, I can’t help here. You know the default suggestion – try to use the latest Firefox and Java on Linux…

    • Check, if you have IPv6 enabled in Java. I had a similar issue, after disabling IPv6 support for Java it worked.

    • I have finally gotten it working.
      There were 3 issues involved:
      1/ Install the latest IPMI firmware.
      — Supermicro sent me the link to firmware revision 142_0712
      — This firmware version warns you of inadequate Java versions.
      2/ Install a recent Java
      — Red Hat recently released Java version java-1.6.0-sun-1.6.0.21-1jpp
      3/ Clear the environment of any proxy servers.
      — I don’t know where javaws found a pointer to my proxy server
      — but the IPMI now works for a new user with no previous environment.

      My software stack:
      – Red Hat Enterprise Linux Server release 5.3 (Tikanga)
      – vnc-server-4.1.2-14.el5_3.1.i386.rpm
      – firefox-3.0.7-1.el5.i386.rpm
      – java-1.6.0-sun-1.6.0.21-1jpp.2.el5.i586.rpm
      – java-1.6.0-sun-plugin-1.6.0.21-1jpp.2.el5.i586.rpm

      Thank you all for your help!

  5. If you kill the VNC server on it, you can fix it by just resetting the IPMI device which won’t affect the server

  6. My X8DTL-iF decided to start spontaneously rebooting every 5 min. after a month of decent serviceability. I did a CC prepay cross-ship w/ SM’s San Jose RMA office and got a non-booting replacement. Another prepay CC cross ship was necessary to finally get a booting board (up 2 days) and it has been showing some of the same behavior as the 1st MB (after issuing “reboot” at Debian prompt next boot would give no video and BIOS beep code for “no memory” (5-4 shorts, 1 long). During this the IPMI interface would not be available. To boot correctly you had to shut off power at the power supply to reset it.
    To address this no memory reboot issue SM tech support suggests that I upgrade BIOS to X8DTL30.528 which dmidecode tells me after application is:

    BIOS Information
    Vendor: American Megatrends Inc.
    Version: 2.0

    BIOS Revision: 8.16

    ……AND to use the latest 2.x _BETA_ IPMI firmware whose release notes are as follows:

    IPMI Firmware Release Note
    ----------------------------
    
    Filename: SMT_202_0727.bin  ver2.02  Date: 07-27-2010
    
    Bug fixes:
    1. H8DGU-LN4F: set GPIO34 to high to fix BIOS hangs with 
    post code '3E' or 'E1' (IssueID=24461)
    2. Add SMTP sender's email (Web gui: Configuration -> SMTP)
    
    =====================================================================================
    Filename: SMT_201_0721.bin  ver2.01  Date: 07-21-2010
    
    Bug fixes:
    1. Fix Lan1 issue for all motherboards with Hartwell (82574) LAN chip
    Description: Cannot connect to BMC use onboard LAN1 after upgrade to new FW.
    Validation: With default setting "failover" or default for non-dedicate LAN MB, 
    BMC connect with LAN1, SUT in OS (WS2008R2, RH5.4, or RH5.5).  Please upgrade FW 
    from previous release version to this new version using web GUI and check whether 
    BMC can connect again after FW flashing.
    
    
    =====================================================================================
    Filename: SMT_200_0720.bin  ver2.00  Date: 07-20-2010
    
    Bug fixes:
    1. X8DTU-LN4F+: Add +1.1V sensor (issueID=24334)
    2. X8DTU-F: Add sensor CPU1 DIMM and CPU2 DIMM (issueID=24269)
    3. X7SPA/X7SPE: Rename sensor name "1.05V" to "Vnbcore" to sync with BIOS
    (issueID=23092)
    

    I’m not applying this yet as I don’t trust it. 3 revisions in 7 days and nothing in them relating to the board they want me to apply it to.

    I used to use SM boards all the time, but this latest board has me looking for a new server hardware vendor. RMA and tech support is HORRIBLE!
    I guess it might be easier if I spoke mandarin Chinese, but I have issues with a foreign vendor doing business in a country when they cannot support the users of that country by understanding their language natively.

    • We actually have used the beta versions, and if the support/developers of Super Micro recommend them, these firmware versions usually work well. At least that’s our experience.
      Try contacting the European Support Team (support@supermicro.nl) about firmware bugs. We’ve got good experience with them. Sometimes I get frustrated with Super Micro too, but don’t be too harsh with them – they do strive to fix things, even if it takes time. 🙂

  7. Where’d you get the changelogs from?

  8. А у меня неприятная вещь впервые связанная с IPMI от Supermicro, На остальных машинах работает нормально

    USB Floppy&Flash :Can not connect to Server!!
    CDROM&ISO :Can not connect to Server!!

    Вот такие веселые сообщения. Не могу загрузиться ISO образа.

  9. 623 port must be open in order to remotely mount images.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s